summaryrefslogtreecommitdiff
authorTing Li <ting.li@amlogic.com>2017-02-10 03:21:26 (GMT)
committer Ting Li <ting.li@amlogic.com>2017-02-10 03:21:26 (GMT)
commitb1c189271a36739ece7275edb930c483bdf9353d (patch)
tree6d1321dee188864c9f4e71aabddcf17a26a9aa9c
parent99598e07981ef108eed185acd1d72030469d6731 (diff)
downloadOTAUpgrade2-b1c189271a36739ece7275edb930c483bdf9353d.zip
OTAUpgrade2-b1c189271a36739ece7275edb930c483bdf9353d.tar.gz
OTAUpgrade2-b1c189271a36739ece7275edb930c483bdf9353d.tar.bz2
pd#136759 do not use abupdate aidl which cause compile error
Change-Id: Iabc0415ee5b7455d7aabbb7c68747c00b833a95a
Diffstat
-rw-r--r--Android.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index b48c7a5..dfa50b4 100644
--- a/Android.mk
+++ b/Android.mk
@@ -4,9 +4,11 @@ include $(CLEAR_VARS)
LOCAL_MODULE_TAGS := optional
LOCAL_STATIC_JAVA_LIBRARIES := libota
LOCAL_SDK_VERSION := current
-LOCAL_SRC_FILES := $(call all-java-files-under, src)\
- $(TOP)/src/android/os/IUpdateEngineCallback.aidl
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+ifneq ($(PLATFORM_SDK_VERSION),23)
+ LOCAL_SRC_FILES += $(TOP)/src/android/os/IUpdateEngineCallback.aidl
+endif
LOCAL_PACKAGE_NAME := OTAUpgrade
LOCAL_CERTIFICATE := platform
LOCAL_DEX_PREOPT := false