summaryrefslogtreecommitdiff
authorTellen Yu <tellen.yu@amlogic.com>2018-01-19 07:59:11 (GMT)
committer Tellen Yu <tellen.yu@amlogic.com>2018-01-25 07:43:35 (GMT)
commit26695afcdb62163ec744a915ed07083464c0999e (patch)
tree39d8cb83ef940f92e6838a6cadd8480f02deb2b1
parent77c50d303ce16c6270efb090b37809a49360175b (diff)
downloadSubTitle-26695afcdb62163ec744a915ed07083464c0999e.zip
SubTitle-26695afcdb62163ec744a915ed07083464c0999e.tar.gz
SubTitle-26695afcdb62163ec744a915ed07083464c0999e.tar.bz2
tvinput: add porting tvinput to HIDL architecture [7/12]
PD# 157786 need use hwbinder instead of binder for RPC since from O Change-Id: I0cf12703c2bfed9ef3d784b6925cf4d0614ce408
Diffstat
-rw-r--r--jni/subtitle/Amsyswrite.cpp2
-rw-r--r--jni/subtitle/Android.mk4
2 files changed, 5 insertions, 1 deletions
diff --git a/jni/subtitle/Amsyswrite.cpp b/jni/subtitle/Amsyswrite.cpp
index 6cc655f..f42ed20 100644
--- a/jni/subtitle/Amsyswrite.cpp
+++ b/jni/subtitle/Amsyswrite.cpp
@@ -14,7 +14,7 @@
#include <MemoryLeakTrackUtilTmp.h>
#include <fcntl.h>
-#include <../../../../frameworks/services/systemcontrol/SystemControlClient.h>
+#include <SystemControlClient.h>
using namespace android;
diff --git a/jni/subtitle/Android.mk b/jni/subtitle/Android.mk
index 9a18fe1..dbb8993 100644
--- a/jni/subtitle/Android.mk
+++ b/jni/subtitle/Android.mk
@@ -12,6 +12,10 @@ LOCAL_C_INCLUDES := $(JNI_H_INCLUDE) \
LOCAL_SHARED_LIBRARIES += libutils libmedia libcutils libbinder libsystemcontrolservice liblog vendor.amlogic.hardware.systemcontrol@1.0_vendor
+LOCAL_C_INCLUDES += \
+ $(BOARD_AML_VENDOR_PATH)frameworks/services/systemcontrol \
+ $(BOARD_AML_VENDOR_PATH)frameworks/services/systemcontrol/PQ/include
+
LOCAL_PRELINK_MODULE := false
ifeq ($(shell test $(PLATFORM_SDK_VERSION) -ge 26 && echo OK),OK)